Issues with deployment creation

Incident Report for Hosted Mender

Resolved

This incident has been resolved, the rollback worked and we'll apply the fix in the next release.
Posted Jun 17, 2026 - 18:36 UTC

Monitoring

We rolled back the affected version and we're monitoring the results
Posted Jun 17, 2026 - 18:17 UTC

Identified

We've identified a regression affecting users who access Mender with a custom role (rather than the built-in administrator role). As a result, we have rolled back to the previous version.

When a user with a custom role attempts to list software when creating a deployment, the request is rejected with There was an error while listing software forbidden by role-based access control

Only users assigned a custom role were affected. Users with the built-in admin role were not affected. We apologize sincerely for this issue.
Posted Jun 17, 2026 - 18:12 UTC
This incident affected: Hosted Mender US and Hosted Mender EU.