API issues with Mender Server

Incident Report for Hosted Mender

Resolved

This incident has been resolved
Posted Oct 22, 2025 - 11:32 UTC

Monitoring

The restore to 08:10:00 UTC has completed at 09:28:49 UTC and the server is scaled back up. We will continue to monitor the situation.
Posted Oct 22, 2025 - 09:44 UTC

Identified

The issue has been identified. A migration triggered by an upgrade caused an index to be removed prematurely. This in turn caused data corruption. We have initiated a database restore and rolled back the upgrade. We apologize for the inconvenience.
Posted Oct 22, 2025 - 09:20 UTC

Update

We are continuing to investigate this issue.
Posted Oct 22, 2025 - 09:07 UTC

Investigating

We noted a spike in API error metrics; we are investigating the issue.
Posted Oct 22, 2025 - 08:56 UTC
This incident affected: Hosted Mender US.