Rate limits issue for some customers

Incident Report for Hosted Mender

Resolved

This incident has been resolved. However, a rate limit hot fix has been implemented, so we will schedule a new maintenance window soon, to apply the definitive fix.
Posted Nov 19, 2025 - 07:55 UTC

Monitoring

We found the root cause, a fix has been implemented, and we're monitoring the results.
Posted Nov 19, 2025 - 06:12 UTC

Identified

We rolled back to the old green cluster, still having the same issue.
Posted Nov 19, 2025 - 06:12 UTC

Investigating

We just upgraded the hosted Mender US cluster to Kubernetes v1.33 with a blue/green approach. The new cluster (blue) right after the switch is experiencing issues with the rate limits for some customer. We are investigating the issue.
Posted Nov 19, 2025 - 05:08 UTC
This incident affected: Hosted Mender US.