Possible issues with the Artifacts Storage

Incident Report for Hosted Mender

Resolved

The upstream provider solved their issue.
Posted Oct 08, 2025 - 09:09 UTC

Identified

We are aware of an open incident with a Cloud Provider for the Artifacts Storage for both hosted Mender US and EU. You may experience slow artifact download or throttling. We're monitoring the upstream provider's status.
Posted Oct 08, 2025 - 03:53 UTC
This incident affected: Hosted Mender US and Hosted Mender EU.