Device inventory APIs rejecting requests with array attributes

Incident Report for Hosted Mender

Resolved

This incident has been resolved.
Posted Aug 30, 2026 - 18:20 UTC

Monitoring

We have rolled back the affected service (inventory) to restore functionality for the affected devices. We are continuing to monitor the situation.
Posted Aug 30, 2026 - 16:44 UTC

Identified

The latest release to hosted Mender on 2026-08-26T12:09Z introduced more optimized indexing of device inventory which had an unintended side effect of denying devices with array-type inventory data.
Posted Aug 30, 2026 - 16:39 UTC
This incident affected: Hosted Mender US and Hosted Mender EU.