Sporadic 504 errors from Deployments API
Incident Report for Hosted Mender
Resolved
Rolled out improvements have been verified to address the issue.
* New Deployments UI with tabbed design
* Deployments and Inventory database connection handling improvements
* Deployments API performance improvements
Posted about 1 year ago. Aug 27, 2018 - 12:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. Aug 23, 2018 - 13:09 UTC
Update
HTTP 504 errors are caused by service taking too long to reply in high traffic spikes.
They used to be masked as HTTP 502 on client side and 499 on our side by load balancer timeouts that have been increased before the weekend. This allows us to distinguish disconnecting clients from internal timeouts however also changed error code on the client side.

We are evaluating options to improve response times in during those periods.
Posted about 1 year ago. Jul 31, 2018 - 08:13 UTC
Investigating
Users experienced sporadic 504 errors returned by Deployments API though the weekend.
The root cause for this is still being investigated however we have increased the overall capacity today as it is likely load-related.
Posted about 1 year ago. Jul 30, 2018 - 17:51 UTC
This incident affected: Hosted Mender.