Kubernetes API Server error increased
Incident Report for Hosted Mender
Resolved
The monitoring system reports no more issues, and we close the incident.
Posted Feb 07, 2024 - 22:03 UTC
Monitoring
At about 14:30 UTC the metrics reported no more issues with no action on our side. We're in contact with the Azure support to check the activities on their side.
Posted Feb 07, 2024 - 18:18 UTC
Update
The Azure support has been involved, but no clear issue is discovered. All services are running fine, including the system pods. The only issue is ~6% of error Read requests in the Kubernetes API server metrics.
We're suspecting an issue with a node and we're going to create an online maintenance window for this evening to restart the nodes of the system pool.
We can confirm that Hosted Mender EU is running without any issue. No new updates are expected until this evening.
Posted Feb 07, 2024 - 11:37 UTC
Investigating
Our metrics are showing increments in the Kubernetes API Server read error. We're investigating the issue.
The Hosted Mender EU service is fully operational.
Posted Feb 07, 2024 - 07:23 UTC
This incident affected: Hosted Mender EU.