Azure Kubernetes Service API Server error
Incident Report for Hosted Mender
Resolved
This incident has been resolved.
Posted Jan 16, 2024 - 11:38 UTC
Monitoring
All the worker nodes have been refreshed online, and the monitoring system is reporting the 5xx issue no more. We are monitoring the results.
Posted Jan 16, 2024 - 10:19 UTC
Identified
The issue has been identified: one of the worker node was in a degraded state, so we started a full node pool refresh.
Posted Jan 16, 2024 - 09:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2024 - 09:29 UTC
Investigating
Our monitoring system is reporting incremented 5xx errors on the Kubernetes API Server requests. The Kubernetes Control Plan is managed by Azure, so we opened a support ticket, and we're troubleshooting the instance in the meantime.
Overall, the Hosted Mender cluster is fully operational.
Posted Jan 16, 2024 - 06:24 UTC
This incident affected: Hosted Mender EU.