API Errors and Resource Spike usage
Incident Report for Hosted Mender
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 14:04 UTC
Monitoring
We are monitoring the hosted Mender statistics and checking for new possible spikes.
Posted Nov 15, 2024 - 11:52 UTC
Identified
The issue has been identified; the database scaled up automatically to address the increased load, so no further actions are needed.
Posted Nov 15, 2024 - 11:50 UTC
Investigating
Today at 11:15 UTC, we observed a sudden spike in workload resources on the hosted Mender. This was accompanied by an increase in API errors. By 11:24 UTC, metrics returned to normal levels, and there have been no further indications of ongoing issues.

The incident appears to have been transient and is no longer impacting the system's functionality.

We are actively investigating the root cause to ensure stability and prevent recurrence.
Posted Nov 15, 2024 - 11:39 UTC
This incident affected: Hosted Mender US.